

<!DOCTYPE html>
<html>
    <head>
        <title>The boys have batted fantastic so far - Wagg | Glamorgan Cricket News</title>
        
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <meta name="description" content="Graham Wagg reacts to Day 2 of the action in the Bob Willis Trophy clash at New Road between Glamorgan and Worcestershire." />
        <meta name="author" content="upriseVSI www.uprisevsi.co.uk" />
        <meta name="viewport" content="width=device-width,initial-scale=1">
        <meta name="theme-color" content="#0b2558">

        <!-- Fonts -->
		<link href="https://fonts.googleapis.com/css?family=Fjalla+One|Roboto:400,500,700|Roboto+Condensed:400,700" rel="stylesheet">

        <!-- OG Facebook -->
        <meta property="og:description" content="Graham Wagg reacts to Day 2 of the action in the Bob Willis Trophy clash at New Road between Glamorgan and Worcestershire."/>
        <meta property="og:title" content='The boys have batted fantastic so far - Wagg'/>
        <meta property="og:image" content='https://www.glamorgancricket.com/documents/og-images/gettyimages-1264654981-15080.jpg' />
        
        <meta property="og:image:type" content='image/jpeg'>
        <meta property="og:image:width" content="1200" />
        <meta property="og:image:height" content="630" />

        <meta property="og:type" content="website"/>
        <meta property="og:site_name" content="Glamorgan Cricket"/>
        <meta property="og:url" content="https://www.glamorgancricket.com/news/the-boys-have-batted-fantastic-so-far-wagg"/>

		<meta name="google-site-verification" content="Pw8nKH8EJ6V4DuIOu6HwlOmZ3tIzSl3a8nbHVx-8ugM" />

        <!-- Twitter -->
        <meta name="twitter:card" content="summary_large_image">
        <meta name='twitter:site' content='@GlamCricket'>
        <meta name="twitter:title" content='The boys have batted fantastic so far - Wagg'>
        <meta name="twitter:description" content="Graham Wagg reacts to Day 2 of the action in the Bob Willis Trophy clash at New Road between Glamorgan and Worcestershire.">
        <meta name='twitter:creator' content='@GlamCricket'>
        <meta name="twitter:image" content='https://www.glamorgancricket.com/documents/twitter-images/gettyimages-1264654981-15081.jpg'>

        <!--Icons-->
        <link rel="shortcut icon" href="https://www.glamorgancricket.com/icons/favicon.ico" type="image/x-icon" />
        <link rel="icon" sizes="192x192" href="https://www.glamorgancricket.com/icons/launcher-icon-4x.png">
        <link rel="icon" sizes="144x144" href="https://www.glamorgancricket.com/icons/launcher-icon-3x.png">
        <link rel="apple-touch-icon" sizes="144x144" href="https://www.glamorgancricket.com/icons/launcher-icon-3x.png">
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.glamorgancricket.com/icons/launcher-icon-3x.png">
    
        <link rel="canonical" href="https://www.glamorgancricket.com/news/the-boys-have-batted-fantastic-so-far-wagg" />

        
            <meta name="robots" content="index, follow" />
        
        <script type="text/javascript">
            var blnCMSEnabled = false;
            function PageLoad() {if(window.LoadMap) { initialize(); }}
            function PageUnload() {if(window.GUnload) { GUnload(); }}
            var siteURL = 'https://www.glamorgancricket.com/';
        </script>

        
    <link rel='stylesheet' type='text/css' href='https://www.glamorgancricket.com/templates/css/fontawesome-pro/font-awesome-pro-v1.min.css'>
<link rel='stylesheet' type='text/css' href='https://www.glamorgancricket.com/templates/css/stylesheet-v104.min.css'>

    <script src='https://www.glamorgancricket.com/templates/js/plugins/jquery-1.8.3-v1.min.js' ></script>
<script src='https://www.glamorgancricket.com/templates/js/plugins/jquery-ui-1.11.14.custom-v1.min.js' ></script>
<script src='https://www.glamorgancricket.com/templates/js/plugins/flexislider-v1.min.js' ></script>
<script src='https://www.glamorgancricket.com/templates/js/plugins/modal-v1.js' ></script>
<script src='https://www.glamorgancricket.com/templates/js/scripts-v21.min.js' ></script>
<script src='https://www.glamorgancricket.com/templates/js/plugins/jquery.jscroll-v1.min.js' ></script>
<script src='https://www.glamorgancricket.com/templates/js/plugins/velocity-v1.min.js' ></script>
<script src='https://www.glamorgancricket.com/templates/js/plugins/velocity-ui-v1.min.js' ></script>


    
    


		<!-- Recaptcha -->
		<script src="https://www.google.com/recaptcha/api.js" async defer></script>

        <!-- Analytics -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-140068767-1', 'auto');
			ga('send', 'pageview');
        </script>

        <!-- Twitter-->
        <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>

		
    </head>

    <body onload="PageLoad()" onunload="PageUnload()">
		<!-- One Tag Conditional Container: ECB  (10512) | ECB_GLA_OneTag (7982) | Export Date: Feb. 26, 2019 @ 12:34pm UTC -->
		<script type="text/javascript">
			var ft_onetag_7982 = {
			    ft_vars:{
			        "ftXRef":"",
			        "ftXValue":"",
			        "ftXType":"",
			        "ftXName":"",
			        "ftXNumItems":"",
			        "ftXCurrency":"",
			        "U1":"",
			        "U2":"",
			        "U3":"",
			        "U4":"",
			        "U5":"",
			        "U6":"",
			        "U7":"",
			        "U8":"",
			        "U9":"",
			        "U10":"",
			        "U11":"",
			        "U12":"",
			        "U13":"",
			        "U14":"",
			        "U15":"",
			        "U16":"",
			        "U17":"",
			        "U18":"",
			        "U19":"",
			        "U20":""
			        },
			    ot_dom:document.location.protocol+'//servedby.flashtalking.com',
			    ot_path:'/container/10512;77534;7982;iframe/?',
			    ot_href:'ft_referrer='+escape(document.location.href),
			    ot_rand:Math.random()*1000000,
			    ot_ref:document.referrer,
			    ot_init:function(){
			        var o=this,qs='',count=0,ns='';
			        for(var key in o.ft_vars){
			            qs+=(o.ft_vars[key]==''?'':key+'='+o.ft_vars[key]+'&');
			        }
			        count=o.ot_path.length+qs.length+o.ot_href+escape(o.ot_ref).length;
			        ns=o.ot_ns(count-2000);
			        document.write('<iframe style="position:absolute; visibility:hidden; width:1px; height:1px;" src="'+o.ot_dom+o.ot_path+qs+o.ot_href+'&ns='+ns+'&cb='+o.ot_rand+'"></iframe>');
			    },
			    ot_ns:function(diff){
			        if(diff>0){
			            var o=this,qo={},
			                sp=/(?:^|&)([^&=]*)=?([^&]*)/g,
			                fp=/^(http[s]?):\/\/?([^:\/\s]+)\/([\w\.]+[^#?\s]+)(.*)?/.exec(o.ot_ref),
			                ro={h:fp[2],p:fp[3],qs:fp[4].replace(sp,function(p1,p2,p3){if(p2)qo[p2]=[p3]})};
			            return escape(ro.h+ro.p.substring(0,10)+(qo.q?'?q='+unescape(qo.q):'?p='+unescape(qo.p)));
			        }else{
			            var o=this;
			            return escape(unescape(o.ot_ref));
			        }
				}
			}
			ft_onetag_7982.ot_init();
		</script>

        <form method="post" action="/news/the-boys-have-batted-fantastic-so-far-wagg" id="ctl00">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
</div>


<script src="/ScriptResource.axd?d=nhGhMbqZIhzvrZ0yAjA6B8wLpXA6a10TDDWu1uaL4BpuptMboHg3Jra6OmjVUyyhFeYxwl7o7xNej6aRyTPnFk9U0Rq7GtS9nmuZnbYD58jsE6HciBDyOiQO4WJqPDN_VKCRXW72QnZLwasu8gMIXUiRI-Zr6-aLJYPGT3ksYVM1&amp;t=ffffffffecf19baa" type="text/javascript"></script>
<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="90059987" />
</div>
            <div id="fb-root"></div>
            <script>(function(d, s, id) {
              var js, fjs = d.getElementsByTagName(s)[0];
              if (d.getElementById(id)) return;
              js = d.createElement(s); js.id = id;
              js.src = "//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.6";
              fjs.parentNode.insertBefore(js, fjs);
            }(document, 'script', 'facebook-jssdk'));</script>

            
            

            <div class="top-header">
                <header id="header" class="header front">
                    <div class="wrapper">
                        <div class="content clear">
                            <div id="header-mobile-left">
                                <a href="#" class="header-mobile-menu"></a>
                            </div>
                            
                            <div id="logo-container">
                                <a href='https://www.glamorgancricket.com/'><img src="https://www.glamorgancricket.com/pics/logo.png" alt="Glamorgan" /></a>
                            </div>
                            <div id="menu-container" class="clear">
                                
                                
<nav class="top-nav topmenu clear">
    <ul class="nav clear">
        
                <li class='menu-button top-level  no-sub
                '>
                    <a title='' href='https://www.glamorgancricket.com/news'>

                    News

                    </a>

                    
                </li>
            
                <li class='menu-button top-level  no-sub
                '>
                    <a title='' href='https://www.glamorgancricket.com/first-team-squad'>

                    Squad

                    </a>

                    
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Fixtures

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                                    <ul>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/first-xi-fixtures'>First XI Fixtures </a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/tables'>First XI Tables</a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/welsh-fire'>Welsh Fire</a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/replay'>Glamorgan Replay</a>
                                            
                                        </li>
                        
                                    </ul>
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Tickets

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                                    <ul>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/ticket-information'>Ticket Information</a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            Match Day Info
                                            
                                                    <ul class="subsubnav">
                                                
                                                    <li class=' '><a title='' href='https://www.glamorgancricket.com/hours-of-play'>Hours of Play</a></li>
                                                
                                                    <li class=' '><a title='' href='https://www.glamorgancricket.com/stadium-seating-plan'>Stadium Seating Plan</a></li>
                                                
                                                    <li class=' '><a title='' href='https://www.glamorgancricket.com/spectators-with-disabilities'>Spectators with Disabilities</a></li>
                                                
                                                    <li class=' '><a title='' href='https://www.glamorgancricket.com/refund-conditions'>Refund & Conditions</a></li>
                                                
                                                    <li class=' '><a title='' href='https://www.glamorgancricket.com/get-to-our-grounds'>Get to our Grounds</a></li>
                                                
                                                    </ul>
                                                
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com//faqs'>FAQs and Refunds</a>
                                            
                                        </li>
                        
                                    </ul>
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Membership

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                                    <ul>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/adult-membership'>Adult Membership</a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/125-club'>125 Club</a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/junior-membership'>Junior Membership</a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/glamorgan-cricket-rewards'>Glamorgan Cricket Rewards</a>
                                            
                                        </li>
                        
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/follow-glamorgan-cricket'>Follow Glamorgan</a>
                                            
                                        </li>
                        
                                    </ul>
                                </div>
                            </div>
                        
                </li>
            

		
		<li class="menu-button top-level">
			<a href="https://www.glamorgancricket.com/worcestershire-glamorgan-080820/preview">Match Zone</a>
		</li>
		

        <li class="header-buttons">
            <div class="headerlinks-wrap">
                <a href="http://www.aswanicricket.co.uk/" class="headerlinks-shop" target="_blank">
                    <img src="https://www.glamorgancricket.com/pics/icon-store.png" alt="Shop" style="max-width: 15px !important;"> 
                    Shop
                </a>
                <a href="https://tickets.glamorgancricket.com/" class="headerlinks-tickets" target="_blank">
                    <img src="https://www.glamorgancricket.com/pics/icon-ticket.png" alt="Tickets" style="max-width: 15px !important;">Tickets
                </a>
            </div>
        </li>
        <li class="header-sophia">
            <a href="https://www.sophiagardens.wales/" target="_blank">
                Visit Our Venue
            </a>
        </li>
    </ul>
</nav>

                                
<nav class="top-nav mainmenu clear">
    <ul class="nav clear">
        
                <li class='menu-button top-level sub
                '>
                    <span>

                    About us

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/our-history'>Club History</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            Our Grounds
                                            
                                                    <ul class="subsubnav">
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/sophia-gardens-cardiff'>Sophia Gardens</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/colwyn-bay'>Colwyn Bay</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/st-helens'>St Helen's</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/newport'>Newport</a></li>
                                                
                                                    </ul>
                                                
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/covid-19'>Covid-19 Update</a>
                                            
                                        </li>
                                    </ul>
                        
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Visit

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/events-calendar'>Calendar</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/museum'>Museum</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/you-said-we-did'>You said, we did</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            Tours & Education
                                            
                                                    <ul class="subsubnav">
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/stadium-tours'>Stadium tours</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/school-visits'>School Visits</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/visites-scolaires-francaises'>Visites Scolaires Francaises</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/self-guided-tour'>Self-guided tour</a></li>
                                                
                                                    </ul>
                                                
                                        </li>
                                    </ul>
                        
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Play Cricket

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/together-through-this-test'>Together Through This Test</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            Cricket in the Community
                                            
                                                    <ul class="subsubnav">
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/all-stars-cricket'>All Stars Cricket</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/ambassador-clubs'>Ambassador Clubs</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/beyond-the-boundaries'>Beyond the boundaries workshops</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/cricket-wales'>Cricket Wales</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/cricket-camps'>Cricket Camps</a></li>
                                                
                                                    </ul>
                                                
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/cricket-wales-foundation'>Cricket Wales Foundation</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/kids'>Kids Zone (Dewi's Den)</a>
                                            
                                                    <ul class="subsubnav">
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/virtual-cricket'>Virtual Cricket Games</a></li>
                                                
                                                    </ul>
                                                
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/national-cricket-centre'>National Cricket Centre</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            Cricket Programmes
                                            
                                                    <ul class="subsubnav">
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/glamorgan-academy'>Glamorgan Academy</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/junior-academy'>Junior Academy</a></li>
                                                
                                                        <li class=' '><a title='' href='https://www.glamorgancricket.com/btec-sports-studies'>BTEC Sports Studies</a></li>
                                                
                                                    </ul>
                                                
                                        </li>
                                    </ul>
                        
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Sophia Gardens

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/sophia-gardens-our-venue'>Our venue</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/a-strictly-christmas'>A Strictly Christmas</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/our-food'>Our Food</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/our-rooms'>Our Rooms</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/hub-xv'>HUB XV</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/special-events'>Special Events</a>
                                            
                                        </li>
                                    </ul>
                        
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Hospitality

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/domestic-hospitality'>Domestic Hospitality</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/the-hundred-hospitality'>The Hundred Hospitality</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/rugby-hospitality'>Six Nations Hospitality</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/international-hospitality'>International Hospitality</a>
                                            
                                        </li>
                                    </ul>
                        
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Sponsors

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/sponsorship-packages'>Sponsorship Packages</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/our-sponsors'>Our Sponsors</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/branding-and-advertising'>Advertising</a>
                                            
                                        </li>
                                    </ul>
                        
                                </div>
                            </div>
                        
                </li>
            
                <li class='menu-button top-level sub
                '>
                    <span>

                    Contact

                    </span>

                    
                            <div class="nav-sub">
                                <div class="nav-sub-links">
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/get-in-touch'>Get In Touch</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/be-a-volunteer'>Be a volunteer</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/customer-charter'>Customer charter</a>
                                            
                                        </li>
                                    </ul>
                        
                                    <ul>
                                        <li class='header  '>
                                            <a title='' href='https://www.glamorgancricket.com/vacancies'>Join our team</a>
                                            
                                        </li>
                                    </ul>
                        
                                </div>
                            </div>
                        
                </li>
            
    </ul>
</nav>
                            </div>
                            

                            <div class="header-buttons __mobile">
                                <div class="headerlinks-wrap">
                                    <a href="https://teamwear.nxt-sports.com/shop/glamorgan-cricket" class="headerlinks-shop" target="_blank">
                                        <img src="https://www.glamorgancricket.com/pics/icon-store.png" alt="Shop" style="max-width: 15px !important;"> 
                                        Shop
                                    </a>
                                    <a href="https://tickets.glamorgancricket.com/" class="headerlinks-tickets" target="_blank">
                                        <img src="https://www.glamorgancricket.com/pics/icon-ticket.png" alt="Tickets" style="max-width: 15px !important;">Tickets
                                    </a>
                                </div>
                            </div>

                            <div class="headerlinks shop">
                                <div class="headerlinks-wrap">
                                    <a href="https://teamwear.nxt-sports.com/shop/glamorgan-cricket" class="headerlinks-shop" target="_blank"><img src="https://www.glamorgancricket.com/pics/icon-store.png" alt="Shop" /> Shop</a>
                                    <a href="https://tickets.glamorgancricket.com/" class="headerlinks-tickets" target="_blank"><img src="https://www.glamorgancricket.com/pics/icon-ticket.png" alt="Tickets" />Tickets</a>
                                </div>
                                <a href="https://www.glamorgancricket.com/sophia-gardens-our-venue" class="headerlinks-sophia" target="_blank">
                                    Visit Our Venue
                                </a>
                            </div>
                        </div>
                    </div>
                </header>
            </div>

            
            <header id="header-stick" class="header front">
                <div class="container clear">

                    <div class="header-sophia">
                        <a href="https://www.sophiagardens.wales/" target="_blank">
                            Visit Our Venue
                        </a>
                    </div>

                    

<nav class="top-nav">
	<ul class="nav clear">
		
				<li class=' '>
					<a  title='' href='https://www.glamorgancricket.com/news'>
						News
					</a>

					
					
					
				</li>
			
				<li class=' '>
					<a  title='' href='https://www.glamorgancricket.com/first-team-squad'>
						Squad
					</a>

					
					
					
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Fixtures
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/first-xi-fixtures'>First XI Fixtures 

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/tables'>First XI Tables

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/welsh-fire'>Welsh Fire

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/replay'>Glamorgan Replay

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Tickets
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/ticket-information'>Ticket Information

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/'>Match Day Info

										<span class='toggle-children'><i class='fas fa-caret-right'></i></span>

										</a>
											<ul class="sub-sub-nav">
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/hours-of-play'>Hours of Play</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/stadium-seating-plan'>Stadium Seating Plan</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/spectators-with-disabilities'>Spectators with Disabilities</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/refund-conditions'>Refund & Conditions</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/get-to-our-grounds'>Get to our Grounds</a></li>
												</ul>
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com//faqs'>FAQs and Refunds

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Membership
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/adult-membership'>Adult Membership

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/125-club'>125 Club

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/junior-membership'>Junior Membership

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/glamorgan-cricket-rewards'>Glamorgan Cricket Rewards

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/follow-glamorgan-cricket'>Follow Glamorgan

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			

		
	</ul>
</nav>
                    

<nav class="top-nav __main">
	<ul class="nav clear">
		
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						About us
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/our-history'>Club History

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/'>Our Grounds

										<span class='toggle-children'><i class='fas fa-caret-right'></i></span>

										</a>
											<ul class="sub-sub-nav">
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/sophia-gardens-cardiff'>Sophia Gardens</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/colwyn-bay'>Colwyn Bay</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/st-helens'>St Helen's</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/newport'>Newport</a></li>
												</ul>
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/covid-19'>Covid-19 Update

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Visit
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/events-calendar'>Calendar

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/museum'>Museum

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/you-said-we-did'>You said, we did

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/'>Tours & Education

										<span class='toggle-children'><i class='fas fa-caret-right'></i></span>

										</a>
											<ul class="sub-sub-nav">
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/stadium-tours'>Stadium tours</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/school-visits'>School Visits</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/visites-scolaires-francaises'>Visites Scolaires Francaises</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/self-guided-tour'>Self-guided tour</a></li>
												</ul>
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Play Cricket
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/together-through-this-test'>Together Through This Test

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/'>Cricket in the Community

										<span class='toggle-children'><i class='fas fa-caret-right'></i></span>

										</a>
											<ul class="sub-sub-nav">
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/all-stars-cricket'>All Stars Cricket</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/ambassador-clubs'>Ambassador Clubs</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/beyond-the-boundaries'>Beyond the boundaries workshops</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/cricket-wales'>Cricket Wales</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/cricket-camps'>Cricket Camps</a></li>
												</ul>
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/cricket-wales-foundation'>Cricket Wales Foundation

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/kids'>Kids Zone (Dewi's Den)

										<span class='toggle-children'><i class='fas fa-caret-right'></i></span>

										</a>
											<ul class="sub-sub-nav">
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/virtual-cricket'>Virtual Cricket Games</a></li>
												</ul>
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/national-cricket-centre'>National Cricket Centre

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/'>Cricket Programmes

										<span class='toggle-children'><i class='fas fa-caret-right'></i></span>

										</a>
											<ul class="sub-sub-nav">
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/glamorgan-academy'>Glamorgan Academy</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/junior-academy'>Junior Academy</a></li>
												
													<li class=" "><a class="sub-sub-a"  title='' href='https://www.glamorgancricket.com/btec-sports-studies'>BTEC Sports Studies</a></li>
												</ul>
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Sophia Gardens
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/sophia-gardens-our-venue'>Our venue

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/a-strictly-christmas'>A Strictly Christmas

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/our-food'>Our Food

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/our-rooms'>Our Rooms

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/hub-xv'>HUB XV

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/special-events'>Special Events

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Hospitality
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/domestic-hospitality'>Domestic Hospitality

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/the-hundred-hospitality'>The Hundred Hospitality

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/rugby-hospitality'>Six Nations Hospitality

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/international-hospitality'>International Hospitality

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Sponsors
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/sponsorship-packages'>Sponsorship Packages

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/our-sponsors'>Our Sponsors

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/branding-and-advertising'>Advertising

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			
				<li class=' '>
					<a onclick='return false;' title='' href='https://www.glamorgancricket.com/'>
						Contact
					</a>

					<span class='toggle-children'><i class='fas fa-caret-right'></i></span>
					
					
							<div class="nav-sub">
								<div class="nav-sub-links">
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/get-in-touch'>Get In Touch

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/be-a-volunteer'>Be a volunteer

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/customer-charter'>Customer charter

										

										</a>
											
										</li>
									</ul>
						
									<ul>
										<li class='header  '><a class="sub-a" title='' href='https://www.glamorgancricket.com/vacancies'>Join our team

										

										</a>
											
										</li>
									</ul>
						
								</div>
							</div>
						
				</li>
			

		
	</ul>
</nav>
                </div>
            </header>
            
            
            <main id="main" class="front ">
                
                
                
                

    <div class="newspage-banner" style='background-image: url(https://www.glamorgancricket.com/documents/blog-banner/gettyimages-1264654981-15079.jpg);'>
        <div class="container">
            <h1>The boys have batted fantastic so far - Wagg</h1>
        </div>
    </div>




    <div class="newspage-wrap">
        <div class="container clear">

                
                
            <div id="page" class="page-left">
                
                <div id="contentArea" itemscope itemtype="http://schema.org/BlogPosting" itemprop="discusses" itemprop="articleBody">
                    
		<div class="newspage-date">
			9 Aug 2020 | Cricket
		</div>
	
					<div id="PageContentMaster_pnlContentBody">
	<p><strong>Glamorgan finished Day 2 at New Road on 181/2 thanks to an unbeaten stand of 137 between Kiran Carlson and Billy Root, after Worcestershire had finished their first innings on 455/8 after the allocated 120 overs.</strong></p>
<p>Graham Wagg had picked up three wickets towards the end of the home side's innings and was relishing the opportunity to rest after a hot first day on a difficult bowling wicket.</p>
<p>"It was nice to get the feet up! The boys have batted fantastic so far.", said Wagg. "It was a lot cooler than yesterday, it was overcast, the ball did swing, and I thought we hit our straps quite well. You can't take away from Libby and D'Oliveira,they played well on a good wicket. There's going to be a lot of toiling out there.</p>
<p>"It is a really good wicket but it was also a new ball wicket. There was a lot of carry early on and the Worcestershire openers bowled really well. The ball gets softer and it gets pretty slow and quite hard to bowl, so the longer we keep them out there the easier it will get for us."</p>
<p>Kiran Carlson (76*) and Billy Root (53*) looked in good touch, especially through the covers as they pierced the infield with regularity throughout the partnership, but Wagg doesn't think the side should get too ahead of themselves too early.</p>
<p>"They were both in pretty good form in pre-season in the intra-squad games, so it's nice to see them carry on.</p>
<p>"We are basically halfway there - we can take a look after the first hour tomorrow, there's still a lot of work to be done with the bat in the morning and after lunch we'll hopefully be in a better position to judge."</p>
<section class="content-section clear"><iframe src="//www.youtube.com/embed/JpgfxVOk9UQ" width="560" height="314" allowfullscreen="allowfullscreen" data-mce-fragment="1"></iframe></section>
<p class="no-margin">&nbsp;</p>
    <div class="newspage-share">
        <span class="button __white">SHARE</span>

        <div class="newspage-sharelinks">
			<!-- Go to www.addthis.com/dashboard to customize your tools --> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5c8faaee1b16bee2"></script>
			<div class="addthis_inline_share_toolbox"></div>

            <style>
                .at-resp-share-element .at-share-btn {
                    padding: 0;
                    margin: 0;
                    background-color: #0b2558 !important;
                }
                .at-icon-wrapper,
                .at-icon {
                    width: 25px !important;
                    height: 25px !important;
                }
                .newspage-sharelinks {
                    padding: 3px 10px 2px;
                }
                .at-resp-share-element .at-share-btn:focus, 
                .at-resp-share-element .at-share-btn:hover {
                    transform: translateY(0);
                } 
                .at-resp-share-element .at-share-btn:hover .at-icon {
                    fill: #ffd302 !important;
                }
            </style>



            
        </div>
    </div>

    <script>
        $Scripts(".newspage-share .button").click(function () {
            $Scripts(".newspage-sharelinks").toggleClass("open");
        });
    </script>

</div>
                    
                </div>
            </div>

                
            <section id="sidebar" class="sidebar-right clear">
                
        <div class="sidebar-title">Latest News</div>
        <div class="sidebar-newswrap">
    
            <a href='https://www.glamorgancricket.com/news/hogans-led-the-attack-brilliantly-harrison' title='Click here to read more about Hogan's led the attack brilliantly - Harrison' class="sidebar-newsitem">
                <div class="sidebar-newsitem-image" style='background-image: url(https://www.glamorgancricket.com/documents/blog-new/gettyimages-1262628843-15074.jpg);'>
                </div>
                <div class="sidebar-newsitem-title">
                    <span>Hogan's led the attack brilliantly - Har...</span>
                </div>
            </a>
    
            <a href='https://www.glamorgancricket.com/news/glamorgan-take-on-worcestershire-in-bob-willis-trophy' title='Click here to read more about Glamorgan take on Worcestershire in Bob Willis Trophy' class="sidebar-newsitem">
                <div class="sidebar-newsitem-image" style='background-image: url(https://www.glamorgancricket.com/documents/blog-new/gettyimages-1263129054-15063.jpg);'>
                </div>
                <div class="sidebar-newsitem-title">
                    <span>Glamorgan take on Worcestershire in Bob...</span>
                </div>
            </a>
    
            <a href='https://www.glamorgancricket.com/news/worcestershire-v-glamorgan-august-8th-11th-head-to-head' title='Click here to read more about Worcestershire v Glamorgan, August 8th-11th: Head-to-Head' class="sidebar-newsitem">
                <div class="sidebar-newsitem-image" style='background-image: url(https://www.glamorgancricket.com/documents/blog-new/81s-eeqrft9xkaecgdo-15044.jpg);'>
                </div>
                <div class="sidebar-newsitem-title">
                    <span>Worcestershire v Glamorgan, August 8th-1...</span>
                </div>
            </a>
    
            <a href='https://www.glamorgancricket.com/news/calling-all-cricket-clubs' title='Click here to read more about Calling all cricket clubs' class="sidebar-newsitem">
                <div class="sidebar-newsitem-image" style='background-image: url(https://www.glamorgancricket.com/documents/blog-new/stadium-flags2-15040.jpg);'>
                </div>
                <div class="sidebar-newsitem-title">
                    <span>Calling all cricket clubs...</span>
                </div>
            </a>
    
        </div>
    

                
            <div class="sidebar-title">News Categories</div>
            <div class="sidebar-categories">
        
                <a href='https://www.glamorgancricket.com/news/category/community' title='Community'>Community</a>
        
                <a href='https://www.glamorgancricket.com/news/category/cricket' title='Cricket'>Cricket</a>
        
                <a href='https://www.glamorgancricket.com/news/category/events' title='Events'>Events</a>
        
                <a href='https://www.glamorgancricket.com/news/category/international' title='International'>International</a>
        
                <a href='https://www.glamorgancricket.com/news/category/matches' title='Matches'>Matches</a>
        
                <a href='https://www.glamorgancricket.com/news/category/my-favourite-game' title='My Favourite Game'>My Favourite Game</a>
        
                <a href='https://www.glamorgancricket.com/news/category/quizzes-and-games' title='Quizzes and Games'>Quizzes and Games</a>
        
                <a href='https://www.glamorgancricket.com/news/category/sponsorship' title='Sponsorship'>Sponsorship</a>
        
                <a href='https://www.glamorgancricket.com/news/category/the-hundred' title='The Hundred'>The Hundred</a>
        
                <a href='https://www.glamorgancricket.com/news/category/world-cup' title='World Cup'>World Cup</a>
        
            </div>
        

                
		<a href='https://www.glamorgancricket.com/nhs' target="_blank" class="sidebar-banner">
			<img src='https://www.glamorgancricket.com/documents/advert/thanks-mpu-13694.jpg' />
		</a>
	


            </section>

                
                
        </div>
    </div>

            </main>
                        
            <footer id="footer" class="front">
                <div class="container">
                    <section class="content-section clear size-3">
                        <div class="content-section-box footer-menu clear">
                            
    

<nav id="footer-nav">
	<ul class="clear">
		
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/adult-membership'>
						Membership
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/first-xi-fixtures'>
						Fixtures
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/events-calendar'>
						Visit
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/tables'>
						Tables
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/cricket-in-the-community'>
						Play Cricket
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/squad'>
						Player Profiles
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/our-venue'>
						Meetings & Events
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/hours-of-play'>
						Match Day Info
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/domestic-hospitality'>
						Hospitality
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/news'>
						News
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/our-sponsors'>
						Sponsors
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/#'>
						Match Zone
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/icc-cricket-world-cup-2019'>
						World Cup
					</a></span>

					
				</li>
			
				<li>
					<span class="menu-header"><a title='' href='https://www.glamorgancricket.com/get-in-touch'>
						Contact
					</a></span>

					
				</li>
			
	</ul>
</nav>


                        </div>

                        <div class="content-section-box footer-social clear">
                            

<div class="social-links">
    <a target="_blank" href="https://www.facebook.com/GlamCricket" title="Find us on Facebook" class="social-link">
        <i class="fab fa-facebook-f"></i>
    </a>
    <a target="_blank" href="https://twitter.com/GlamCricket" title="Follow us on Twitter" class="social-link">
        <i class="fab fa-twitter"></i>
    </a>
    <a target="_blank" href="https://www.instagram.com/glamcricket/" title="Follow us on Instagram" class="social-link">
        <i class="fab fa-instagram"></i>
    </a>
    <a target="_blank" href="https://www.youtube.com/user/glamorgancricketclub" title="Watch us on Youtube" class="social-link">
        <i class="fab fa-youtube"></i>
    </a>

    
</div>
                            <div class="footer-contact">
                                <p>Tel: <a href="tel:02920409380">02920 409 380</a></p>
                                <p>Email: <a href="mailto:info@glamorgancricket.co.uk">info@glamorgancricket.co.uk</a></p>
                            </div>
                        </div>
                        <div class="content-section-box footer-info clear">
                            <img src="https://www.glamorgancricket.com/pics/footer-logos.png">
                            <p class="footer-address">
                                GLAMORGAN COUNTY CRICKET CLUB<br>
                                Sophia Gardens, Cardiff, CF11 9XR</p>
                            <p class="copyright">
                                &#169;2020 All Rights Reserved |
                                <a href="https://www.glamorgancricket.com/documents/dp0101-gccc-privacy-policy-v10-24518-7476.pdf" target="_blank">Privacy Policy</a> | <a href="https://www.glamorgancricket.com/cookie-policy">Cookies Policy</a><br>
                                Web Design by <a href="https://www.uprisevsi.co.uk/services/responsive-web-design" target="_blank" title="UpriseVSI Web Design and Web Development Agency">upriseVSI</a>
                            </p>
                        </div>
                    </section>
                </div>              
            </footer>

            <section id="cookie-notification" class="front">
                <div class="container clear">
                    <p>This website uses cookies to ensure you get the best experience on our website. 
                    <a href="https://www.glamorgancricket.com/cookie-policy" title="Click here to read our privacy and cookie policy" target="_blank">Learn more</a></p>

                    <a class="button cookie-notification-close">Got it!</a>
                </div>
            </section>

            
            
    
       
        </form>
    </body>
</html>